PT-2011-1239

CVE-2011-1468

·

تاريخ النشر

2011-03-19

·

تاريخ التحديث

2018-10-30

الوصف من

CVSS 2.0
4.3
متوسطة
المقاييسAV:N/AC:M/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.3.6
Description The issue is related to errors in resource management in the OpenSSL extension of the PHP programming language. It may allow a remote attacker to cause a denial of service. The problem is associated with memory leaks in the OpenSSL extension, which can be triggered by sending plaintext data to the openssl encrypt function or ciphertext data to the openssl decrypt function.
Recommendations For PHP versions prior to 5.3.6, update to version 5.3.6 or later to resolve the issue. As a temporary workaround, consider restricting the use of the openssl encrypt and openssl decrypt functions to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
DSA-2408-1
RHSA-2011:1423
RHSA-2011_1423
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾