PT-2011-2352

CVE-2011-0449

·

تاريخ النشر

2011-02-21

·

تاريخ التحديث

2019-08-08

الوصف من

CVSS 2.0
7.5
عالية
المقاييسAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Ruby on Rails versions 3.0.x through 3.0.3
Description The issue allows remote attackers to bypass intended access restrictions via an action name that uses an unintended case for alphabetic characters, when a case-insensitive filesystem is used. This occurs due to improper implementation of filters associated with the list of available templates in the actionpack/lib/action view/template/resolver.rb file.
Recommendations For Ruby on Rails versions 3.0.x through 3.0.3, update to version 3.0.4 or later to resolve the issue.
قابلية الاستغلال
استغلال
إصلاح
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-4WW3-3RXJ-8V6Q
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾