PT-2011-3679

CVE-2011-2202

·

تاريخ النشر

2011-06-16

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 2.0
6.4
متوسطة
المقاييسAV:N/AC:L/Au:N/C:N/I:P/A:P
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.3.7
Description The issue concerns a problem with the rfc1867 post handler function in PHP, which does not properly restrict filenames in multipart/form-data POST requests. This allows remote attackers to conduct absolute path traversal attacks and possibly create or overwrite arbitrary files through a crafted upload request. The issue is related to a "file path injection vulnerability."
Recommendations For PHP versions prior to 5.3.7, update to version 5.3.7 or later to resolve the issue. As a temporary workaround, consider restricting access to the rfc1867 post handler function in main/rfc1867.c to minimize the risk of exploitation. Avoid using the vulnerable function until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
DSA-2266-1
OPENSUSE-SU-2024:10290-1
OPENSUSE-SU-2024:10344-1
OPENSUSE-SU-2024:11169-1
RHSA-2011:1423
RHSA-2011_1423
RHSA-2012:0033
RHSA-2012_0033
RHSA-2012:0071
RHSA-2012_0071
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾