PT-2011-4188
CVE-2011-2929
·
تاريخ النشر
2011-08-29
·
تاريخ التحديث
2019-08-08
الوصف من
CVSS 2.0
5.0
متوسطةالمقاييسAV:N/AC:L/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Ruby on Rails versions 3.0.x through 3.0.9
Ruby on Rails versions 3.1.x through 3.1.0.rc5
Description
The template selection functionality in actionpack/lib/action view/template/resolver.rb does not properly handle glob characters, allowing remote attackers to render arbitrary views via a crafted URL, related to a "filter skipping vulnerability."
Recommendations
For Ruby on Rails versions 3.0.x through 3.0.9, update to version 3.0.10 or later.
For Ruby on Rails versions 3.1.x through 3.1.0.rc5, update to version 3.1.0.rc6 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾