PT-2012-1037
CVE-2012-4561
·
تاريخ النشر
2012-11-30
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 2.0
7.5
عاليةالمقاييسAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
libssh versions prior to 0.5.3
Description
The issue affects multiple functions in keys.c in libssh, including publickey make dss, publickey make rsa, signature from string, ssh do sign, and ssh sign session id. This might allow remote attackers to cause a denial of service via unspecified vectors. Exploitation of the vulnerabilities can lead to disruption of confidentiality, integrity, and availability of protected information and can be carried out remotely.
Recommendations
For versions prior to 0.5.3, update to version 0.5.3 or later to resolve the issue.
As a temporary workaround, consider restricting access to the vulnerable functions until a patch is available.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾