PT-2012-1116
CVE-2012-3410
·
تاريخ النشر
2012-08-13
·
تاريخ التحديث
2017-08-29
الوصف من
CVSS 2.0
6.9
متوسطةالمقاييسAV:L/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
GNU Bash versions prior to 4.2 patch 33
GNU Bash versions prior to 4.2 p37
Description
The issue is related to a stack-based buffer overflow in lib/sh/eaccess.c, which might allow local users to bypass intended restricted shell access. This can be achieved by using a long filename in /dev/fd, which is not properly handled when expanding the /dev/fd prefix. Multiple vulnerabilities in the bash package, specifically in versions before 4.2 p37, can lead to breaches of confidentiality, integrity, and availability of protected information. These vulnerabilities can be exploited locally.
Recommendations
For GNU Bash versions prior to 4.2 patch 33, update to version 4.2 patch 33 or later.
For GNU Bash versions prior to 4.2 p37, update to version 4.2 p37 or later.
As a temporary workaround, consider restricting access to the /dev/fd directory to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾