PT-2012-2963
CVE-2012-0936
·
تاريخ النشر
2012-01-29
·
تاريخ التحديث
2017-08-29
الوصف من
CVSS 2.0
4.3
متوسطةالمقاييسAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
OpenNMS versions 1.8.x through 1.8.16
OpenNMS versions 1.9.x through 1.9.93
OpenNMS versions 1.10.x through 1.10.0
Description
A cross-site scripting (XSS) issue allows remote attackers to inject arbitrary web script or HTML via the
Username field, related to login. This is due to a vulnerability in the web/springframework/security/SecurityAuthenticationEventOnmsEventBuilder.java component.Recommendations
For OpenNMS versions 1.8.x through 1.8.16, update to version 1.8.17 or later.
For OpenNMS versions 1.9.x through 1.9.93, update to a version later than 1.9.93.
For OpenNMS versions 1.10.x through 1.10.0, update to version 1.10.1 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾