PT-2012-3113

CVE-2012-1184

·

تاريخ النشر

2012-09-18

·

تاريخ التحديث

2017-08-29

الوصف من

CVSS 2.0
7.5
عالية
المقاييسAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Asterisk versions 1.8.x through 1.8.10.0 Asterisk versions 10.x through 10.2.0
Description The issue is related to a stack-based buffer overflow in the ast parse digest function, which can be triggered by a long string in an HTTP Digest Authentication header. This can cause a denial of service (crash) or possibly allow remote attackers to execute arbitrary code.
Recommendations For Asterisk versions 1.8.x through 1.8.10.0, update to version 1.8.10.1 or later. For Asterisk versions 10.x through 10.2.0, update to version 10.2.1 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾