PT-2012-3909

CVE-2012-2269

·

تاريخ النشر

2012-04-20

·

تاريخ التحديث

2025-03-31

الوصف من

CVSS 2.0
4.3
متوسطة
المقاييسAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions ownCloud versions prior to 3.0.3
Description The issue allows remote attackers to inject arbitrary web script or HTML, potentially leading to cross-site scripting (XSS) attacks. This can be achieved through various means, including injecting script into specific fields or parameters in several PHP files, such as apps/contacts/ajax/addcard.php, apps/contacts/ajax/addproperty.php, apps/contacts/ajax/createaddressbook, files/download.php, and files/index.php. The vulnerable parameters include name, user, redirect url, and file.
Recommendations For ownCloud versions prior to 3.0.3, update to version 3.0.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the vulnerable PHP files and parameters, such as apps/contacts/ajax/addcard.php, apps/contacts/ajax/addproperty.php, apps/contacts/ajax/createaddressbook, files/download.php, and files/index.php, and avoid using the vulnerable parameters name, user, redirect url, and file in the affected API endpoints until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾