PT-2012-4165

CVE-2012-2660

·

تاريخ النشر

2012-06-22

·

تاريخ التحديث

2019-08-08

الوصف من

CVSS 2.0
6.4
متوسطة
المقاييسAV:N/AC:L/Au:N/C:P/I:P/A:N
Name of the Vulnerable Software and Affected Versions Ruby on Rails versions prior to 2.3.16 Ruby on Rails versions 3.0.x through 3.0.12 Ruby on Rails versions 3.1.x through 3.1.4 Ruby on Rails versions 3.2.x through 3.2.3
Description The issue allows remote attackers to bypass intended database-query restrictions and perform NULL checks via a crafted request. This is due to improper consideration of differences in parameter handling between the Active Record component and the Rack interface. The vulnerability can be exploited by sending certain "[nil]" values in a request.
Recommendations For Ruby on Rails versions prior to 2.3.16, update to version 2.3.16 or later. For Ruby on Rails versions 3.0.x through 3.0.12, update to version 3.0.13 or later. For Ruby on Rails versions 3.1.x through 3.1.4, update to version 3.1.5 or later. For Ruby on Rails versions 3.2.x through 3.2.3, update to version 3.2.4 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-HGPP-PP89-4FGF
OPENSUSE-SU-2012_0978-1
RHSA-2013:0582
SUSE-SU-2012_1012-1
SUSE-SU-2012_1015-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾