PT-2012-4166
CVE-2012-2661
·
تاريخ النشر
2012-06-22
·
تاريخ التحديث
2019-08-08
الوصف من
CVSS 2.0
5.0
متوسطةالمقاييسAV:N/AC:L/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Ruby on Rails versions 3.0.x through 3.0.12
Ruby on Rails versions 3.1.x through 3.1.4
Ruby on Rails versions 3.2.x through 3.2.3
Description
The issue is related to the Active Record component, which does not properly handle the passing of request data to a where method in an ActiveRecord class. This allows remote attackers to conduct certain SQL injection attacks via nested query parameters that leverage unintended recursion.
Recommendations
For Ruby on Rails versions 3.0.x through 3.0.12, update to version 3.0.13 or later.
For Ruby on Rails versions 3.1.x through 3.1.4, update to version 3.1.5 or later.
For Ruby on Rails versions 3.2.x through 3.2.3, update to version 3.2.4 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾