PT-2012-4187
CVE-2012-2694
·
تاريخ النشر
2012-06-22
·
تاريخ التحديث
2019-08-08
الوصف من
CVSS 2.0
4.3
متوسطةالمقاييسAV:N/AC:M/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Ruby on Rails versions 3.0.0 through 3.0.13
Ruby on Rails versions 3.1.0 through 3.1.5
Ruby on Rails versions 3.2.0 through 3.2.5
Description
The issue arises from improper consideration of differences in parameter handling between the Active Record component and the Rack interface in Ruby on Rails. This allows remote attackers to bypass intended database-query restrictions and perform NULL checks via a crafted request. For example, certain values like
['xyz', nil] can be used to demonstrate this issue.Recommendations
For Ruby on Rails versions 3.0.0 through 3.0.13, update to version 3.0.14 or later.
For Ruby on Rails versions 3.1.0 through 3.1.5, update to version 3.1.6 or later.
For Ruby on Rails versions 3.2.0 through 3.2.5, update to version 3.2.6 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾