PT-2012-4188

CVE-2012-2695

·

تاريخ النشر

2012-06-22

·

تاريخ التحديث

2019-08-08

الوصف من

CVSS 2.0
7.5
عالية
المقاييسAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Ruby on Rails versions prior to 2.3.15 Ruby on Rails versions 3.0.x through 3.0.14 Ruby on Rails versions 3.1.x through 3.1.6 Ruby on Rails versions 3.2.x through 3.2.6
Description The Active Record component in Ruby on Rails does not properly implement the passing of request data to a where method in an ActiveRecord class. This allows remote attackers to conduct certain SQL injection attacks via nested query parameters that leverage improper handling of nested hashes.
Recommendations For Ruby on Rails versions prior to 2.3.15, update to version 2.3.15 or later. For Ruby on Rails versions 3.0.x through 3.0.14, update to version 3.0.14 or later. For Ruby on Rails versions 3.1.x through 3.1.6, update to version 3.1.6 or later. For Ruby on Rails versions 3.2.x through 3.2.6, update to version 3.2.6 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-76WQ-XW4H-F8WJ
OPENSUSE-SU-2013_0278-1
OPENSUSE-SU-2013_0280-1
RHSA-2013:0582
SUSE-SU-2012_1011-1
SUSE-SU-2012_1014-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾