PT-2012-4733

CVE-2012-3463

·

تاريخ النشر

2012-08-10

·

تاريخ التحديث

2019-08-08

الوصف من

CVSS 2.0
4.3
متوسطة
المقاييسAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions Ruby on Rails versions 3.0.0 through 3.0.16 Ruby on Rails versions 3.1.0 through 3.1.7 Ruby on Rails versions 3.2.0 through 3.2.7
Description A cross-site scripting (XSS) issue allows remote attackers to inject arbitrary web script or HTML via the prompt field to the select tag helper in the actionpack/lib/action view/helpers/form tag helper.rb file. This enables attackers to execute malicious scripts on the client-side.
Recommendations For Ruby on Rails versions 3.0.0 through 3.0.16, update to version 3.0.17 or later. For Ruby on Rails versions 3.1.0 through 3.1.7, update to version 3.1.8 or later. For Ruby on Rails versions 3.2.0 through 3.2.7, update to version 3.2.8 or later.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-98MF-8F57-64QF
RHSA-2013:0582
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾