PT-2012-4740

CVE-2012-3471

·

تاريخ النشر

2012-08-12

·

تاريخ التحديث

2012-08-13

الوصف من

CVSS 2.0
7.5
عالية
المقاييسAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Ushahidi Platform versions prior to 2.5
Description The issue concerns SQL injection vulnerabilities in the edit functions of certain PHP files within the Ushahidi Platform. Specifically, the vulnerabilities are located in the application/controllers/admin/reports.php and application/controllers/members/reports.php files. These vulnerabilities allow remote attackers to execute arbitrary SQL commands via an incident id.
Recommendations For versions prior to 2.5, update to version 2.5 or later to resolve the issue. As a temporary workaround, consider restricting access to the reports.php files in the admin and members controllers to minimize the risk of exploitation. Avoid using the incident id parameter in the affected API endpoints until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾