PT-2013-1134

CVE-2013-2062

·

تاريخ النشر

2013-06-15

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 2.0
6.8
متوسطة
المقاييسAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions libXp versions 1.0.1 and earlier xorg-server versions prior to 1.14.3-r2 libXext versions 1.3.2 and earlier libX11 versions 1.6.0 and earlier libXt versions 1.1.4 and earlier libXfixes versions 5.0.1 and earlier libXinerama versions 1.1.3 and earlier libXp-devel versions 1.0.2 and earlier libXt-devel versions 1.1.4 and earlier libXfixes-devel versions 5.0.1 and earlier libXinerama-devel versions 1.1.3 and earlier libXres versions 1.0.7 and earlier libXres-devel versions 1.0.7 and earlier libXrandr versions 1.4.1 and earlier libXrandr-devel versions 1.4.1 and earlier libXv versions 1.0.9 and earlier libXi versions 1.7.2 and earlier libXi-devel versions 1.7.2 and earlier libXcursor versions 1.1.14 and earlier libXcursor-devel versions 1.1.14 and earlier libXrender versions 0.9.8 and earlier libXrender-devel versions 0.9.8 and earlier libXtst versions 1.2.2 and earlier libXtst-debuginfo versions 1.2.2 and earlier libXvMC versions 1.0.8 and earlier libX11-common versions 1.6.0 and earlier libXxf86dga versions 1.1.4 and earlier libXxf86vm versions 1.1.3 and earlier xcb-proto versions 1.8 and earlier libdmx versions 1.1.3 and earlier
Description The issue is related to multiple vulnerabilities in various packages of the Red Hat Enterprise Linux, Debian GNU/Linux, and Gentoo Linux operating systems. These vulnerabilities can be exploited remotely, leading to a breach of confidentiality, integrity, and availability of protected information. The vulnerabilities are related to integer overflows in the X.org libXp package, which can cause allocation of insufficient memory and a buffer overflow via vectors related to the XpGetAttributes, XpGetOneAttribute, XpGetPrinterList, and XpQueryScreens functions.
Recommendations For libXp versions 1.0.1 and earlier, update to a version later than 1.0.1. For xorg-server versions prior to 1.14.3-r2, update to version 1.14.3-r2 or later. For libXext versions 1.3.2 and earlier, update to a version later than 1.3.2. For libX11 versions 1.6.0 and earlier, update to a version later than 1.6.0. For libXt versions 1.1.4 and earlier, update to a version later than 1.1.4. For libXfixes versions 5.0.1 and earlier, update to a version later than 5.0.1. For libXinerama versions 1.1.3 and earlier, update to a version later than 1.1.3. For libXp-devel versions 1.0.2 and earlier, update to a version later than 1.0.2. For libXt-devel versions 1.1.4 and earlier, update to a version later than 1.1.4. For libXfixes-devel versions 5.0.1 and earlier, update to a version later than 5.0.1. For libXinerama-devel versions 1.1.3 and earlier, update to a version later than 1.1.3. For libXres versions 1.0.7 and earlier, update to a version later than 1.0.7. For libXres-devel versions 1.0.7 and earlier, update to a version later than 1.0.7. For libXrandr versions 1.4.1 and earlier, update to a version later than 1.4.1. For libXrandr-devel versions 1.4.1 and earlier, update to a version later than 1.4.1. For libXv versions 1.0.9 and earlier, update to a version later than 1.0.9. For libXi versions 1.7.2 and earlier, update to a version later than 1.7.2. For libXi-devel versions 1.7.2 and earlier, update to a version later than 1.7.2. For libXcursor versions 1.1.14 and earlier, update to a version later than 1.1.14. For libXcursor-devel versions 1.1.14 and earlier, update to a version later than 1.1.14. For libXrender versions 0.9.8 and earlier, update to a version later than 0.9.8. For libXrender-devel versions 0.9.8 and earlier, update to a version later than 0.9.8. For libXtst versions 1.2.2 and earlier, update to a version later than 1.2.2. For libXtst-debuginfo versions 1.2.2 and earlier, update to a version later than 1.2.2. For libXvMC versions 1.0.8 and earlier, update to a version later than 1.0.8. For libX11-common versions 1.6.0 and earlier, update to a version later than 1.6.0. For libXxf86dga versions 1.1.4 and earlier, update to a version later than 1.1.4. For libXxf86vm versions 1.1.3 and earlier, update to a version later than 1.1.3. For xcb-proto versions 1.8 and earlier, update to a version later than 1.8. For libdmx versions 1.1.3 and earlier, update to a version later than 1.1.3.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾