PT-2013-1217

CVE-2013-2236

·

تاريخ النشر

2013-10-10

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 2.0
5.0
متوسطة
المقاييسAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions Quagga versions prior to 0.99.22.2 Quagga versions prior to 0.99.22.4
Description The issue is related to a stack-based buffer overflow in the new msg lsa change notify function within the OSPFD API. This can be exploited by remote attackers to cause a denial of service, specifically a crash, by sending a large LSA when certain conditions are met, such as the use of --enable-opaque-lsa and the -a command line option. Multiple vulnerabilities in the Quagga package can lead to disruption of protected information availability, and these can be exploited remotely.
Recommendations For versions prior to 0.99.22.2, update to version 0.99.22.2 or later. For versions prior to 0.99.22.4, update to version 0.99.22.4 or later. As a temporary workaround, consider restricting access to the OSPFD API or disabling the new msg lsa change notify function until a patch is available.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2014-2059
CESA-2017_0794
DSA-2803-1
MGASA-2013-0310
OPENSUSE-SU-2024:10362-1
RHSA-2017:0794
RHSA-2017_0794
USN-2941-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾