PT-2013-1233

CVE-2013-3567

·

تاريخ النشر

2013-06-26

·

تاريخ التحديث

2019-07-10

الوصف من

CVSS 2.0
9.0
عالية
المقاييسAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Puppet versions 2.7.x prior to 2.7.23 Puppet versions 3.2.x prior to 3.2.2 Puppet Enterprise versions prior to 2.8.2
Description The issue allows remote attackers to instantiate arbitrary Ruby classes and execute arbitrary code via a crafted REST API call, potentially leading to a breach of confidentiality, integrity, and availability of protected information. This can be exploited by an authenticated attacker.
Recommendations For Puppet versions 2.7.x prior to 2.7.23, update to version 2.7.23 or later. For Puppet versions 3.2.x prior to 3.2.2, update to version 3.2.2 or later. For Puppet Enterprise versions prior to 2.8.2, update to version 2.8.2 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-F7P5-W2CR-7CP7
DSA-2715-1
MGASA-2013-0187
OPENSUSE-SU-2013_1370-1
OPENSUSE-SU-2024:10581-1
RHSA-2013:1283
RHSA-2013:1284
SUSE-RU-2015:0696-1
SUSE-SU-2013_1304-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾