PT-2013-1357
CVE-2013-2251
·
تاريخ النشر
2013-05-23
·
تاريخ التحديث
2025-03-13
الوصف من
CVSS 2.0
9.3
عاليةالمقاييسAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Apache Struts versions 2.0.0 through 2.3.15
Description
The issue is related to the improper sanitization of input data in the DefaultActionMapper mechanism of Apache Struts. This allows a remote attacker to execute arbitrary OGNL expressions by crafting parameters with specific prefixes, such as
action:, redirect:, or redirectAction:. The vulnerability can be exploited to execute server-side code.Recommendations
For Apache Struts versions 2.0.0 through 2.3.15, update to a version later than 2.3.15.1 to resolve the issue. As a temporary workaround, consider restricting the use of parameters with the
action:, redirect:, and redirectAction: prefixes to minimize the risk of exploitation.قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾