PT-2013-1882

CVE-2012-6089

·

تاريخ النشر

2013-01-04

·

تاريخ التحديث

2018-03-04

الوصف من

CVSS 2.0
7.5
عالية
المقاييسAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions SWI-Prolog versions prior to 6.2.5 SWI-Prolog versions 6.3.x prior to 6.3.7
Description The issue is related to multiple stack-based buffer overflows in the canoniseFileName function. This can be exploited by remote attackers using a crafted filename, potentially leading to a denial of service or the execution of arbitrary code.
Recommendations For SWI-Prolog versions prior to 6.2.5, update to version 6.2.5 or later. For SWI-Prolog versions 6.3.x prior to 6.3.7, update to version 6.3.7 or later.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2018-1360
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾