PT-2013-4901

CVE-2013-4212

·

تاريخ النشر

2013-12-07

·

تاريخ التحديث

2017-08-29

الوصف من

CVSS 2.0
6.8
متوسطة
المقاييسAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Apache Roller versions prior to 5.0.2
Description The issue allows remote attackers to execute arbitrary OGNL expressions via certain parameters, such as the pageTitle parameter in the !getPageTitle sub-URL to roller-ui/login.rol. This is possible due to certain getText methods in the ActionSupport controller.
Recommendations For Apache Roller versions prior to 5.0.2, update to version 5.0.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the roller-ui/login.rol URL and its subclasses, such as UIAction, to minimize the risk of exploitation. Avoid using the pageTitle parameter in the !getPageTitle sub-URL until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾