PT-2013-5118

CVE-2013-4660

·

تاريخ النشر

2013-06-28

·

تاريخ التحديث

2025-12-02

الوصف من

CVSS 2.0
6.8
متوسطة
المقاييسAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions js-yaml versions 2.0.4 and earlier
Description The issue allows remote attackers to execute arbitrary code via a crafted string that triggers an eval operation, due to the JS-YAML module parsing input without properly considering the unsafe !!js/function tag.
Recommendations Update to version 2.0.5 or later, and ensure that all instances where the load() method is called are updated to use safeLoad() instead.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-XXVW-45RP-3MJ2
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾