PT-2013-5177
CVE-2013-4758
·
تاريخ النشر
2013-10-04
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 2.0
6.8
متوسطةالمقاييسAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
rsyslog versions prior to 7.4.2
rsyslog versions prior to 7.5.2 devel
Description
The issue is related to a double free vulnerability in the writeDataError function within the ElasticSearch plugin (omelasticsearch) of rsyslog. This vulnerability can be exploited by remote attackers when the errorfile is set to local logging, allowing them to cause a denial of service (crash) and potentially execute arbitrary code via a crafted JSON response.
Recommendations
For versions prior to 7.4.2, update to version 7.4.2 or later.
For versions prior to 7.5.2 devel, update to version 7.5.2 devel or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾