PT-2013-5723

CVE-2013-5679

·

تاريخ النشر

2013-09-30

·

تاريخ التحديث

2022-05-17

الوصف من

CVSS 2.0
2.6
منخفضة
المقاييسAV:L/AC:H/Au:N/C:P/I:P/A:N
Name of the Vulnerable Software and Affected Versions OWASP Enterprise Security API (ESAPI) for Java versions prior to 2.1.0
Description The issue concerns the authenticated-encryption feature in the symmetric-encryption implementation, which does not properly resist tampering with serialized ciphertext. This makes it easier for remote attackers to bypass intended cryptographic protection mechanisms via an attack against authenticity in the default configuration, involving a null MAC and a zero MAC length.
Recommendations For versions prior to 2.1.0, update to version 2.1.0 or later to resolve the issue.
قابلية الاستغلال
استغلال
إصلاح
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-JCP9-796G-PV9P
MGASA-2015-0064
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾