PT-2013-6038

CVE-2013-6415

·

تاريخ النشر

2013-12-07

·

تاريخ التحديث

2019-08-08

الوصف من

CVSS 2.0
4.3
متوسطة
المقاييسAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions Ruby on Rails versions prior to 3.2.16 Ruby on Rails versions 4.x prior to 4.0.2
Description A cross-site scripting (XSS) issue exists in the number to currency helper, allowing remote attackers to inject arbitrary web script or HTML via the unit parameter. This enables attackers to execute malicious scripts on the client-side.
Recommendations For Ruby on Rails versions prior to 3.2.16, update to version 3.2.16 or later. For Ruby on Rails versions 4.x prior to 4.0.2, update to version 4.0.2 or later. As a temporary workaround, consider restricting the use of the number to currency helper until a patch is applied.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-6H5Q-96HP-9JGM
DSA-2888-1
RHSA-2013:1794
RHSA-2014:0008
SUSE-SU-2014_0154-1
SUSE-SU-2014_0154-2
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾