PT-2014-1282

CVE-2014-0066

·

تاريخ النشر

2014-02-21

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 2.0
4.0
متوسطة
المقاييسAV:N/AC:L/Au:S/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions PostgreSQL versions prior to 8.4.20 PostgreSQL versions 9.0.x prior to 9.0.16 PostgreSQL versions 9.1.x prior to 9.1.12 PostgreSQL versions 9.2.x prior to 9.2.7 PostgreSQL versions 9.3.x prior to 9.3.3
Description The issue is related to the improper handling of input data by one of the functions associated with data encryption in PostgreSQL. This allows a remote authenticated user to cause a denial of service, resulting in a crash due to a null pointer dereference. The problem is specifically linked to the chkpass extension not properly checking the return value of the crypt library function.
Recommendations For PostgreSQL versions prior to 8.4.20, update to version 8.4.20 or later. For PostgreSQL versions 9.0.x prior to 9.0.16, update to version 9.0.16 or later. For PostgreSQL versions 9.1.x prior to 9.1.12, update to version 9.1.12 or later. For PostgreSQL versions 9.2.x prior to 9.2.7, update to version 9.2.7 or later. For PostgreSQL versions 9.3.x prior to 9.3.3, update to version 9.3.3 or later. As a temporary workaround, consider restricting access to the chkpass extension until a patch is applied.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
CESA-2014_0211
CESA-2014_0221
DSA-2864-1
DSA-2865-1
MGASA-2014-0205
MGASA-2014-0222
OPENSUSE-SU-2024:10030-1
OPENSUSE-SU-2024:10256-1
OPENSUSE-SU-2024:10273-1
RHSA-2014:0211
RHSA-2014_0211
RHSA-2014:0221
RHSA-2014:0249
RHSA-2014_0249
RHSA-2014:0469
USN-2120-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾