PT-2014-1413
CVE-2014-3597
·
تاريخ النشر
2014-08-22
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 2.0
6.8
متوسطةالمقاييسAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.4.32
PHP versions 5.5.x prior to 5.5.16
Description
The issue is related to multiple buffer overflows in the
php parserr function, which can be exploited by remote DNS servers using crafted DNS records. This can lead to a denial of service (application crash) or possibly the execution of arbitrary code. The dns get record and dn expand functions are involved in this issue.Recommendations
For PHP versions prior to 5.4.32, update to version 5.4.32 or later.
For PHP versions 5.5.x prior to 5.5.16, update to version 5.5.16 or later.
As a temporary workaround, consider restricting access to the
dns get record and dn expand functions until a patch is available. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾