PT-2014-1437
CVE-2014-0231
·
تاريخ النشر
2014-07-14
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 2.0
5.0
متوسطةالمقاييسAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
Apache HTTP Server versions prior to 2.4.10
Description
The issue is related to the mod cgid module, which lacks a timeout mechanism. This allows remote attackers to cause a denial of service (process hang) by sending a request to a CGI script that does not read from its stdin file descriptor. A flaw in mod cgid can cause child processes to hang indefinitely if a server hosts CGI scripts that do not consume standard input, leading to denial of service.
Recommendations
For versions prior to 2.4.10, update to version 2.4.10 or later to resolve the issue. As a temporary workaround, consider restricting access to CGI scripts that do not consume standard input to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾