PT-2014-1700

CVE-2014-3509

·

تاريخ النشر

2014-08-06

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 2.0
6.8
متوسطة
المقاييسAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions OpenSSL versions 1.0.0 through 1.0.0n OpenSSL versions 1.0.1 through 1.0.1i
Description A race condition in the ssl parse serverhello tlsext function in OpenSSL, when multithreading and session resumption are used, allows remote SSL servers to cause a denial of service (memory overwrite and client application crash) or possibly have unspecified other impact by sending Elliptic Curve (EC) Supported Point Formats Extension data. This issue may lead to disruption of confidentiality, integrity, and availability of protected information. The issue can be exploited remotely.
Recommendations For OpenSSL versions 1.0.0 through 1.0.0n, update to version 1.0.0n or later. For OpenSSL versions 1.0.1 through 1.0.1i, update to version 1.0.1i or later. As a temporary workaround, consider disabling the ssl parse serverhello tlsext function until a patch is available. Restrict access to the t1 lib.c library to minimize the risk of exploitation. Avoid using the Elliptic Curve (EC) Supported Point Formats Extension data in the affected API endpoint until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2014-2312
CESA-2014_1052
DSA-2998-1
MGASA-2014-0325
OPENSUSE-SU-2024:10271-1
OPENSUSE-SU-2024:10309-1
OPENSUSE-SU-2024:10529-1
OPENSUSE-SU-2024:11127-1
RHSA-2014:1052
RHSA-2014_1052
RHSA-2014:1054
RHSA-2015:0197
SUSE-FU-2022:0445-1
SUSE-RU-2015:0769-1
SUSE-SU-2015:0546-1
SUSE-SU-2015:1185-1
USN-2308-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾