PT-2014-1701

CVE-2014-5139

·

تاريخ النشر

2014-08-06

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 2.0
4.3
متوسطة
المقاييسAV:N/AC:M/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions OpenSSL versions 1.0.1 through 1.0.1i OpenSSL versions prior to 1.0.1j
Description The issue allows remote SSL servers to cause a denial of service, resulting in a NULL pointer dereference and client application crash. This can be achieved through a ServerHello message that includes an SRP ciphersuite without the required negotiation of that ciphersuite with the client. The vulnerability may lead to disruption of confidentiality, integrity, and availability of protected information and can be exploited remotely.
Recommendations For OpenSSL versions 1.0.1 through 1.0.1i, update to version 1.0.1i or later to resolve the issue. For OpenSSL versions prior to 1.0.1j, update to version 1.0.1j or later to resolve the issue. As a temporary workaround, consider restricting the use of SRP ciphersuites in ServerHello messages until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2014-2312
DSA-2998-1
MGASA-2014-0325
OPENSUSE-SU-2024:10271-1
OPENSUSE-SU-2024:10309-1
OPENSUSE-SU-2024:10529-1
OPENSUSE-SU-2024:11127-1
SUSE-FU-2022:0445-1
SUSE-RU-2015:0769-1
SUSE-SU-2015:0546-1
SUSE-SU-2015:1185-1
USN-2308-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾