PT-2014-1840

CVE-2014-9295

·

تاريخ النشر

2014-12-19

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 2.0
7.5
عالية
المقاييسAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions NTP versions prior to 4.2.8
Description The issue is related to multiple stack-based buffer overflows in the ntpd service, which can be exploited by remote attackers to execute arbitrary code via crafted packets. This is related to the crypto recv function when the Autokey Authentication feature is used, the ctl putdata function, and the configure function. The vulnerability can be exploited remotely, potentially leading to disruption of confidentiality, integrity, and availability of protected information.
Recommendations For versions prior to 4.2.8, update to version 4.2.8 or later to resolve the issue. As a temporary workaround, consider disabling the crypto recv function when the Autokey Authentication feature is used, the ctl putdata function, and the configure function until a patch is available. Restrict access to the vulnerable ntpd service to minimize the risk of exploitation. Avoid using the vulnerable functions and features in the affected API endpoints until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2014-2486
CESA-2014_2024
DLA-116-1
DSA-3108-1
HPSBUX03240
MGASA-2014-0541
OPENSUSE-SU-2014_1670-1
OPENSUSE-SU-2024:10181-1
RHSA-2014:2024
RHSA-2014_2024
RHSA-2014:2025
RHSA-2014_2025
RHSA-2015:0104
SUSE-SU-2014_1686-1
SUSE-SU-2014_1686-2
SUSE-SU-2014_1686-3
SUSE-SU-2014_1690-1
SUSE-SU-2015:0259-1
SUSE-SU-2015:0259-2
SUSE-SU-2015:0259-3
SUSE-SU-2015:1173-1
USN-2449-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾