PT-2014-2038
CVE-2014-8142
·
تاريخ النشر
2014-12-20
·
تاريخ التحديث
2016-12-31
الوصف من
CVSS 2.0
7.5
عاليةالمقاييسAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.4.36
PHP versions 5.5.x prior to 5.5.20
PHP versions 5.6.x prior to 5.6.4
Description
The issue is related to a use-after-free vulnerability in the
process nested data function. This vulnerability can be exploited by a remote attacker to execute arbitrary code via a crafted unserialize call. The exploitation is possible due to improper handling of duplicate keys within the serialized properties of an object.Recommendations
For PHP versions prior to 5.4.36, update to version 5.4.36 or later.
For PHP versions 5.5.x prior to 5.5.20, update to version 5.5.20 or later.
For PHP versions 5.6.x prior to 5.6.4, update to version 5.6.4 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾