PT-2014-2039
CVE-2014-3668
·
تاريخ النشر
2014-07-18
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 2.0
7.8
عاليةالمقاييسAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.4.34
PHP versions 5.5.x prior to 5.5.18
PHP versions 5.6.x prior to 5.6.2
Description
The issue is caused by a buffer overflow in the date from ISO8601 function in the mkgmtime implementation in libxmlrpc/xmlrpc.c in the XMLRPC extension. This allows remote attackers to cause a denial of service (application crash) via a crafted first argument to the
xmlrpc set type function or a crafted argument to the xmlrpc decode function, related to an out-of-bounds read operation.Recommendations
For PHP versions prior to 5.4.34, update to version 5.4.34 or later.
For PHP versions 5.5.x prior to 5.5.18, update to version 5.5.18 or later.
For PHP versions 5.6.x prior to 5.6.2, update to version 5.6.2 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾