PT-2014-2047

CVE-2015-0231

·

تاريخ النشر

2014-12-30

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 2.0
7.5
عالية
المقاييسAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions PHP versions 5.4.x through 5.4.36 PHP versions 5.5.x through 5.5.20 PHP versions 5.6.x through 5.6.4
Description The issue is related to a use-after-free vulnerability in the process nested data function in ext/standard/var unserializer.re in PHP. This vulnerability allows remote attackers to execute arbitrary code via a crafted unserialize call that leverages improper handling of duplicate numerical keys within the serialized properties of an object.
Recommendations For PHP versions 5.4.x through 5.4.36, update to version 5.4.37 or later. For PHP versions 5.5.x through 5.5.20, update to version 5.5.21 or later. For PHP versions 5.6.x through 5.6.4, update to version 5.6.5 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
CESA-2015_1135
DSA-3195-1
HPSBUX03337
MGASA-2015-0040
OPENSUSE-SU-2024:10290-1
OPENSUSE-SU-2024:10344-1
OPENSUSE-SU-2024:11169-1
RHSA-2015:1053
RHSA-2015:1066
RHSA-2015:1135
RHSA-2015_1135
SUSE-SU-2015:0365-1
SUSE-SU-2016:1638-1
USN-2501-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾