PT-2014-3101

CVE-2013-6396

·

تاريخ النشر

2014-02-18

·

تاريخ التحديث

2022-05-17

الوصف من

CVSS 4.0
9.3
حرجة
المقاييسAV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions python-swiftclient versions 1.0 through 1.9.0 python-swiftclient versions 1.0 through 2.0.1
Description The issue concerns the failure of the python-swiftclient to verify X.509 certificates from SSL servers. This allows man-in-the-middle attackers to spoof servers and obtain sensitive information via a crafted certificate.
Recommendations For python-swiftclient versions 1.0 through 1.9.0, update to version 2.0.2 or later to resolve the issue. For python-swiftclient versions 1.0 through 2.0.1, update to version 2.0.2 or later to resolve the issue.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-P3XV-97G8-4WMJ
PYSEC-2014-12
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾