PT-2014-5351

CVE-2014-3483

·

تاريخ النشر

2014-07-07

·

تاريخ التحديث

2019-08-08

الوصف من

CVSS 2.0
7.5
عالية
المقاييسAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions Ruby on Rails versions 4.0.0 through 4.0.6 Ruby on Rails versions 4.1.0 through 4.1.2
Description The issue is related to a SQL injection vulnerability in the PostgreSQL adapter for Active Record. This vulnerability allows remote attackers to execute arbitrary SQL commands by leveraging improper range quoting.
Recommendations For Ruby on Rails versions 4.0.0 through 4.0.6, update to version 4.0.7 or later. For Ruby on Rails versions 4.1.0 through 4.1.2, update to version 4.1.3 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-R8FH-HQ2P-7QHQ
DSA-2982-1
MGASA-2014-0303
RHSA-2014:0877
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾