PT-2014-6238
CVE-2014-4975
·
تاريخ النشر
2014-07-17
·
تاريخ التحديث
2017-08-29
الوصف من
CVSS 2.0
5.0
متوسطةالمقاييسAV:N/AC:L/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Ruby versions 1.9.3 and earlier
Ruby versions 2.x through 2.1.2
Description
The issue is related to an off-by-one error in the encodes function in pack.c. This error can be triggered when using certain format string specifiers, allowing attackers to cause a denial of service, specifically a segmentation fault, via vectors that trigger a stack-based buffer overflow.
Recommendations
For Ruby versions 1.9.3 and earlier, update to a version later than 1.9.3 to resolve the issue.
For Ruby versions 2.x through 2.1.2, update to a version later than 2.1.2 to resolve the issue.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾