PT-2014-6378

CVE-2014-5265

·

تاريخ النشر

2014-08-18

·

تاريخ التحديث

2015-11-25

الوصف من

CVSS 2.0
5.0
متوسطة
المقاييسAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions Incutio XML-RPC (IXR) Library as used in WordPress versions prior to 3.9.2 Incutio XML-RPC (IXR) Library as used in Drupal versions prior to 6.33 Incutio XML-RPC (IXR) Library as used in Drupal versions prior to 7.31
Description The issue allows remote attackers to cause a denial of service, consuming memory and CPU, via a crafted XML document containing a large number of nested entity references. This is due to the library permitting entity declarations without considering recursion during entity expansion.
Recommendations For WordPress versions prior to 3.9.2, update to version 3.9.2 or later. For Drupal 6.x versions prior to 6.33, update to version 6.33 or later. For Drupal 7.x versions prior to 7.31, update to version 7.31 or later.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
DLA-56-1
DSA-2999-1
DSA-3001-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾