PT-2015-1438

CVE-2015-2731

·

تاريخ النشر

2015-07-02

·

تاريخ التحديث

2024-12-12

الوصف من

CVSS 2.0
10
عالية
المقاييسAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Mozilla Firefox versions prior to 39.0 Mozilla Firefox ESR versions 38.x prior to 38.1 Thunderbird versions prior to 38.1
Description The issue is related to a use-after-free vulnerability in the CSPService::ShouldLoad function, which can be exploited by remote attackers to execute arbitrary code on the client side. This is achieved by leveraging client-side JavaScript that triggers the removal of a DOM object based on a Content Policy, allowing for manipulation of the DOM object. The vulnerability is associated with the use of memory after it has been freed.
Recommendations For Mozilla Firefox versions prior to 39.0, update to version 39.0 or later. For Mozilla Firefox ESR versions 38.x prior to 38.1, update to version 38.1 or later. For Thunderbird versions prior to 38.1, update to version 38.1 or later. As a temporary workaround, consider restricting the use of client-side JavaScript that triggers the removal of DOM objects based on Content Policy until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
ALT-PU-2015-1667
ALT-PU-2015-1669
ALT-PU-2015-2040
CESA-2015_1207
CESA-2015_1455
DSA-3300-1
OPENSUSE-SU-2015_1229-1
OPENSUSE-SU-2024:10071-1
OPENSUSE-SU-2024:10230-1
OPENSUSE-SU-2024:14572-1
RHSA-2015:1207
RHSA-2015_1207
RHSA-2015:1455
RHSA-2015_1455
USN-2656-1
USN-2656-2
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾