PT-2015-3199
CVE-2015-8805
·
تاريخ النشر
2015-12-31
·
تاريخ التحديث
2018-10-30
الوصف من
CVSS 3.1
9.8
حرجةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Nettle versions prior to 3.2
Description
The issue is related to errors in the encryption algorithm of the ecc 256 modq function in the Nettle cryptographic library. This can allow a remote attacker to impact the integrity, availability, and confidentiality of information. The ecc 256 modq function does not properly handle carry propagation and produces incorrect output in its implementation of the P-256 NIST elliptic curve.
Recommendations
For versions prior to 3.2, update to version 3.2 or later to resolve the issue. As a temporary workaround, consider restricting the use of the ecc 256 modq function until a patch is available.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾