PT-2015-3226

CVE-2015-7215

·

تاريخ النشر

2015-12-15

·

تاريخ التحديث

2024-12-12

الوصف من

CVSS 2.0
5.0
متوسطة
المقاييسAV:N/AC:L/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions Mozilla Firefox versions prior to 43.0
Description The issue is related to the importScripts function in the Web Workers API implementation, which lacks protection of internal data. This can be exploited by a remote attacker to bypass the existing access restriction policy, leading to information disclosure. The exploitation involves triggering the use of the no-cors mode in the fetch API to attempt resource access that throws an exception.
Recommendations For versions prior to 43.0, update to version 43.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the importScripts function until a patch is available. Avoid using the no-cors mode in the fetch API for sensitive resource access until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2015-2196
ALT-PU-2016-1454
MGASA-2016-0124
OPENSUSE-SU-2024:10071-1
OPENSUSE-SU-2024:14572-1
USN-2833-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾