PT-2015-3249
CVE-2015-3412
·
تاريخ النشر
2015-06-23
·
تاريخ التحديث
2019-04-22
الوصف من
CVSS 3.1
5.3
متوسطةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.4.40
PHP versions 5.5.x prior to 5.5.24
PHP versions 5.6.x prior to 5.6.8
Description
The issue is related to the lack of checking for %00 sequences in pathnames, which could allow remote attackers to read arbitrary files by providing crafted input to an application that uses the stream resolve include path function. This can be exploited by using a filename0.extension attack, bypassing intended configuration restrictions on file extensions that clients can read.
Recommendations
For PHP versions prior to 5.4.40, update to version 5.4.40 or later.
For PHP versions 5.5.x prior to 5.5.24, update to version 5.5.24 or later.
For PHP versions 5.6.x prior to 5.6.8, update to version 5.6.8 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾