PT-2015-3430
CVE-2015-4025
·
تاريخ النشر
2015-05-18
·
تاريخ التحديث
2019-04-22
الوصف من
CVSS 2.0
7.5
عاليةالمقاييسAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.4.41
PHP versions 5.5.x prior to 5.5.25
PHP versions 5.6.x prior to 5.6.9
Description
The issue is related to an error in handling file paths containing the x00 character. This can allow a remote attacker to gain unauthorized access to files or directories. The vulnerability can be exploited by providing a crafted argument to functions such as
set include path, tempnam, rmdir, or readlink.Recommendations
For PHP versions prior to 5.4.41, update to version 5.4.41 or later.
For PHP versions 5.5.x prior to 5.5.25, update to version 5.5.25 or later.
For PHP versions 5.6.x prior to 5.6.9, update to version 5.6.9 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾