PT-2015-3628

CVE-2014-100021

·

تاريخ النشر

2015-01-13

·

تاريخ التحديث

2015-01-14

الوصف من

CVSS 2.0
4.3
متوسطة
المقاييسAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions OrangeHRM versions prior to 3.1.2
Description A cross-site scripting (XSS) issue allows remote attackers to inject arbitrary web script or HTML via the empsearch[employee name][empId] parameter in the /pim/viewEmployeeList endpoint.
Recommendations For versions prior to 3.1.2, update to version 3.1.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the /pim/viewEmployeeList endpoint to minimize the risk of exploitation. Avoid using the empsearch[employee name][empId] parameter in the affected endpoint until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾