PT-2015-5243

CVE-2015-1368

·

تاريخ النشر

2015-01-27

·

تاريخ التحديث

2018-10-09

الوصف من

CVSS 2.0
4.3
متوسطة
المقاييسAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions Ansible Tower versions prior to 2.0.5
Description The issue allows remote attackers to inject arbitrary web script or HTML. This can be achieved via the order by parameter to various endpoints such as "credentials/", "inventories/", "projects/", or "users/3/permissions/" in "api/v1/" or the next run parameter to "api/v1/schedules/".
Recommendations For versions prior to 2.0.5, update to version 2.0.5 or later to resolve the issue. As a temporary workaround, consider restricting access to the vulnerable API endpoints, such as "api/v1/credentials/", "api/v1/inventories/", "api/v1/projects/", "api/v1/users/3/permissions/", and "api/v1/schedules/", until a patch is applied. Avoid using the order by and next run parameters in the affected API endpoints until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾