PT-2015-5700

CVE-2015-2294

·

تاريخ النشر

2015-04-01

·

تاريخ التحديث

2019-05-30

الوصف من

CVSS 2.0
4.3
متوسطة
المقاييسAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions pfSense versions prior to 2.2.1
Description The issue allows remote attackers to inject arbitrary web script or HTML via various parameters in different PHP files, including status captiveportal.php, firewall rules.php, firewall shaper.php, services unbound acls.php, and diag logs filter.php. The vulnerable parameters include zone, if, dragtable, queue, id, filterlogentries time, filterlogentries sourceipaddress, filterlogentries sourceport, filterlogentries destinationipaddress, filterlogentries interfaces, filterlogentries destinationport, filterlogentries protocolflags, and filterlogentries qty.
Recommendations For versions prior to 2.2.1, update to version 2.2.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the WebGUI and limiting user input to minimize the risk of exploitation. Avoid using the vulnerable parameters in the affected API endpoints until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾