PT-2015-6085

CVE-2015-3166

·

تاريخ النشر

2015-05-22

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions PostgreSQL versions prior to 9.0.20 PostgreSQL versions 9.1.x prior to 9.1.16 PostgreSQL versions 9.2.x prior to 9.2.11 PostgreSQL versions 9.3.x prior to 9.3.7 PostgreSQL versions 9.4.x prior to 9.4.2
Description The issue is related to the snprintf implementation, which does not properly handle system-call errors. This can allow attackers to obtain sensitive information or have other unspecified impact via unknown vectors, such as an out-of-memory error.
Recommendations For versions prior to 9.0.20, update to version 9.0.20 or later. For versions 9.1.x prior to 9.1.16, update to version 9.1.16 or later. For versions 9.2.x prior to 9.2.11, update to version 9.2.11 or later. For versions 9.3.x prior to 9.3.7, update to version 9.3.7 or later. For versions 9.4.x prior to 9.4.2, update to version 9.4.2 or later.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
CESA-2015_1194
DLA-227-1
DSA-3269-1
DSA-3269-2
DSA-3270-1
MGASA-2015-0250
OPENSUSE-SU-2024:10030-1
OPENSUSE-SU-2024:10256-1
OPENSUSE-SU-2024:10273-1
RHSA-2015:1194
RHSA-2015_1194
RHSA-2015:1195
RHSA-2015:1196
SUSE-SU-2015:1264-1
USN-2621-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾