PT-2015-6106

CVE-2015-3227

·

تاريخ النشر

2015-07-26

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 2.0
5.0
متوسطة
المقاييسAV:N/AC:L/Au:N/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions Ruby on Rails versions prior to 4.1.11 Ruby on Rails versions 4.2.x prior to 4.2.2
Description The issue allows remote attackers to cause a denial of service (SystemStackError) via a large XML document depth when JDOM or REXML is enabled in the jdom.rb and rexml.rb components in Active Support.
Recommendations For Ruby on Rails versions prior to 4.1.11, update to version 4.1.11 or later. For Ruby on Rails versions 4.2.x prior to 4.2.2, update to version 4.2.2 or later. As a temporary workaround, consider disabling the JDOM or REXML components until a patch is available.
قابلية الاستغلال
إصلاح
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-35C4-F3RQ-F9G3
GHSA-J96R-XVJQ-R9PG
DLA-603-1
DSA-3464-1
OPENSUSE-SU-2024:10574-1
SUSE-SU-2016:0047-1
SUSE-SU-2016_0047-1
SUSE-SU-2016:0082-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾