PT-2015-6650
CVE-2015-4647
·
تاريخ النشر
2015-06-24
·
تاريخ التحديث
2016-12-07
الوصف من
CVSS 2.0
6.8
متوسطةالمقاييسAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Panasonic Security API (PS-API) ActiveX SDK versions prior to 8.10.18
Description
The issue concerns stack-based buffer overflows in the Ipropsapi component of the Panasonic Security API (PS-API) ActiveX SDK. This can be exploited by remote attackers to execute arbitrary code via a long string in the
FilePassword property or to the GetStringInfo method.Recommendations
For versions prior to 8.10.18, update to version 8.10.18 or later to resolve the issue. As a temporary workaround, consider restricting access to the
FilePassword property and the GetStringInfo method until a patch is applied. Avoid using long strings in these components to minimize the risk of exploitation. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾