PT-2015-6827

CVE-2015-5276

·

تاريخ النشر

2015-10-07

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 2.0
5.0
متوسطة
المقاييسAV:N/AC:L/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions GNU Compiler Collection (GCC) versions prior to 4.9.4
Description The issue concerns the std::random device class in libstdc++ which does not handle short reads from blocking sources properly. This makes it easier for attackers to predict random values.
Recommendations For versions prior to 4.9.4, update to version 4.9.4 or later to resolve the issue.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2019-1174
MGASA-2015-0449
OPENSUSE-SU-2024:10542-1
SUSE-SU-2015:1833-1
SUSE-SU-2015_1833-1
SUSE-SU-2016:0908-2
SUSE-SU-2016_0908-2
SUSE-SU-2016:0963-1
SUSE-SU-2016_0963-1
SUSE-SU-2017:0379-1
SUSE-SU-2017_0379-1
SUSE-SU-2017:2235-1
SUSE-SU-2017_2235-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾